Back to overview
Degraded
Our backend services have stability issues
Mar 19, 2024 at 03:27pm UTC
Affected services
API Production
Supplier Dashboard
Resolved
Mar 19, 2024 at 08:19pm UTC
The performance are back to normal.
Affected services
Created
Mar 19, 2024 at 03:27pm UTC
You may have degraded performance on API and Supplier interface
Affected services